maandag 3 november 2008

Dode pixels?

Gisteren ontdekte ik iets fantastisch door wat te lezen op DPreview.
Eerst de voorgeschiedenis:
Ik dacht al een tijdje dat mijn toestel een aantal dode pixels begon te krijgen:
In foto's als deze twee, waren verscheidene pixels (telkens dezelfde) in het donkere achtergronddeel rood of groen, in plaats van donker.

GeAr_20080929_148 GeAr_20080929_031

In detail (100%) ziet dat er zo uit:
GeAr_20080929_148
"Verdikkeme, het wordt tijd voor een nieuw toestel", dacht ik. 

Maar wat las ik op DPreview?
Bij lange sluitertijden krijg je soms "hot pixels". Pixels die opwarmen door de lange sluitertijd (of zoiets, het heeft ook met stroompjes en zo te maken dacht ik) kunnen foute informatie doorgeven.
Bijvoorbeeld: een pixel kan rood of groen lijken, terwijl hij gewoon niet goed heeft geregistreerd.
Dat is makkelijk op te lossen!
Bij lange sluitertijden, kan ik mijn toestel "lange sluitertijden ruisreductie" laten doen. Wat er dan gebeurt is eigenlijk heel simpel. Het toestel neemt een foto met een sluitertijd van bijvoorbeeld 12 seconden. Nadat de foto is genomen zal het nog 12 seconden "denken". Op dat moment is de spiegel naar beneden, de sluiter is dicht. Het toestel moet dus een perfect zwarte foto maken. Maar die "hot pixels" geven geen zwart, maar rood of groen (in mijn geval)!
Het toestel vindt die pixels, en elimineert ze dan in het beeld!
Resultaat: nikske hot pixels meer zichtbaar in uw foto!
Nadeel: "lange sluitertijden ruisreductie" moet aanstaan. Ik had het natuurlijk een tijd geleden uitgeschakeld met het idee: "ruis haal ik er wel uit in nabewerking". Nu staat het dus weer aan, leve Custom Function 2.
Ander nadeel: Als je een foto neemt van 10 seconden, is je toestel 20 seconden bezig (10 sec met de sluiter open + 10 sec met de sluiter dicht), bij een sluitertijd van 10 minuten, is je toestel dus 20 minuten bezig, enz.
Om het te testen, heb ik mijn kast gefotografeerd :-).
GeAr_20081103_101
en met ruisreductie aan zie je ze beiden niet meer terug!
GeAr_20081103_102

4 opmerkingen:

PJ Volders zei

Zeer interessant! Zeker aangezien ik onlangs ook een dode pixel ontdekte... Bij de 2e foto lijkt er wel meer ruis te zijn in het zwart, kan dit?

groetjes
PJ

sgaap zei

Het lijkt me ook zo dat er meer ruis zit in de 2de foto (met ruisreductie). Tis altijd iets mee die kodakken! En ze stak een nief b&w rolleke in hare analogen.

Gert Arijs zei

(ik wilde onderstaande link als link, maar dat mislukte tweemaal)
Ah, maar toen stond mijn computerscherm nog op, en dus kwam er meer licht tot aan de kast. Zoom maar eens goed in, dan zie je dat de eerste foto iets donkerder is, en meer ruis heeft. Maar omdat hij donkerder is, valt dat niet op.
http://www.flickr.com/photos/gertarijs/3003117043/sizes/l/

Otto Van De Steene zei

Ik heb die custom functie ook al eens getest. En ja, het duurt mottig lang als je het gebruikt. Ik heb het altijd op automatisch aan staan.

Leuk detail is dat modernere toestellen daar steeds minder last van beginnen te krijgen. Sind de ontwikkeling naar 5D mII lijkt heb probleem me zelfs nihiel te worden. Ik denk dat dit komt omdat deze sensors wat minder snel warm worden...

(kan je trouwens niet beter een linkt naar het artikel zelf plaatsen?)